CA18DET Engine Problems

Go down

CA18DET Engine Problems

Post by Sushiman on Thu 26 Apr 2007, 12:00 pm

Hey, I have been working on putting a CA18DET into a 240sx(with a KA24). I'm having a problem though. My engine is having the symptoms of a bad air flow meter(wont let me rev past 2500 rpm or it will stall...im running rich...etc). I read my engine codes and it gave me a code 12(bad or missing air flow meter). I just checked my air flow meter voltages and they are all correct(during idle 1.6v and at 2500rpm 2.2v). That means my air flow meter is good, but my ECU is still not detecting it. When I was doing the converstion I had to add the Ignition Coil Relay(because the KA24 doesn't require one). Before I put the relay in, my car wouldn't start, it would just keep turning over. Once I put the relay in, it then worked. I'm assuming this means I put it in correctly. There is another point of interest I have which might be causing a problem(but im not sure because I know nothing about alternators). On my wiring harness I have two grounds which are supposed to connect to my alternator, however on my alternator there is only a place to connect one(I remember on my last CA18DET I had two connectors on my alternator). Right now, I have one ground hooked up and the other is just hanging there. If i touch the hanging ground to any metal it will spark and blow my alternator fuse. Could this be causing my problem? Perhaps my air flow meter is not getting enough power? I'm not sure. I am really stumped on this problem. If anyone has information which might help, or if you need to know more info, just ask and I'll do my best to answer

Sushiman
Casual
Casual

Male
Number of posts : 4
Age : 36
Registration date : 2007-04-26

View user profile

Back to top Go down

Re: CA18DET Engine Problems

Post by Drift_Instructor on Thu 26 Apr 2007, 2:36 pm

firstly use paragraphs or dot points

secondly if you are going to put in a CA18DET...why do you not just do that now instead of spending time, effort and frustrations on the KA24?

other than that i cant help you.. try posting your question at nissansilvia.com
avatar
Drift_Instructor
Forum Administrator
Forum Administrator

Male
Number of posts : 2892
Age : 106
Location : Melbourne
Ride : Soarer+Low+Eurolines=PHAT
Comments : R.I.P Anthony. Fucken Legend
Registration date : 2007-04-22

View user profile

Back to top Go down

Re: CA18DET Engine Problems

Post by Drift_Instructor on Thu 26 Apr 2007, 2:41 pm

just quickley..if your in Aus..why do you have a KA24?

if all s13s in aus were privatly imported from japan (Which they were as they were never locally sold) they would either have an Sr20det or Ca18det

wernt the KA24's only in the euro models of the s13's?

get back to me


Last edited by on Wed 30 May 2007, 12:49 pm; edited 1 time in total
avatar
Drift_Instructor
Forum Administrator
Forum Administrator

Male
Number of posts : 2892
Age : 106
Location : Melbourne
Ride : Soarer+Low+Eurolines=PHAT
Comments : R.I.P Anthony. Fucken Legend
Registration date : 2007-04-22

View user profile

Back to top Go down

Re: CA18DET Engine Problems

Post by RdS: on Fri 27 Apr 2007, 4:32 am

yeah.. im guessing he's from the US. KA24's were only here in the nissan bluebird. but all S13/S14 silvia/hatch/180 variations in the us had the 2.4na KA24 ONLY. hence the name '240sx' and the fact he actually wants to put in a CA18 Laughing
avatar
RdS:
MEGA WHORE!
MEGA WHORE!

Number of posts : 2375
Registration date : 2007-04-25

View user profile

Back to top Go down

Re: CA18DET Engine Problems

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum